Apache Syncope Audit Events Search Flaw Enables SQL Injection
Vulnerability Disclosure · 2 sources · Updated 3mo ago · First seen Jul 20, 2026

Apache Syncope disclosed CVE-2026-57308, an important SQL injection vulnerability in the Audit Events search functionality that can let an authenticated administrator with sufficient entitlements execute arbitrary SQL through stacked queries. The issue is caused by improper neutralization of special elements in SQL commands, specifically unsanitized sort parameters handled by the application.
The vulnerability affects Apache Syncope versions 3.0.0-M0 through 3.0.16, 4.0.0-M0 through 4.0.6, and 4.1.0-M0 through 4.1.1. Apache advised users to upgrade to 4.0.7 or 4.1.2 to remediate the flaw, and credited Lennart Hostettler with reporting the issue.


