Critical Flowise Authentication Bypass Lets Attackers Forge Admin JWTs
A critical vulnerability tracked as **CVE-2026-56271** allows remote attackers to bypass authentication in **Flowise** by forging valid JWTs and impersonating arbitrary users, including administrators. The flaw affects versions before **3.1.0**, including **3.0.13** and earlier, and stems from weak hardcoded default JWT secrets plus default audience and issuer values in the enterprise passport authentication middleware.
When the relevant JWT environment variables are not explicitly configured, Flowise falls back to publicly known defaults, effectively embedding insecure default credentials into the authentication path. The issue is rated **CVSS v3.1 9.8** and **CVSS v4.0 9.3** as remotely exploitable, and remediation guidance calls for upgrading to **Flowise 3.1.0 or later** and setting strong, unique JWT secrets along with custom audience and issuer values.
Jul 12, 2026
Critical Flowise RCE Vulnerability CVE-2025-61913 Enables Arbitrary File Read and Write
A critical remote code execution vulnerability, tracked as CVE-2025-61913, has been identified in Flowise, a drag-and-drop user interface for building customized large language model flows. The flaw exists in versions prior to 3.0.8 and is caused by insufficient restrictions in the WriteFileTool and ReadFileTool components, which fail to properly validate file path access. This oversight allows authenticated attackers to read and write arbitrary files to any location on the file system, significantly increasing the risk of remote code execution. The vulnerability has been assigned a CVSS score of 10.0, indicating its maximum severity and potential for exploitation. According to security advisories, the issue can be exploited remotely, making it a high-priority concern for organizations using affected versions of Flowise. The vulnerability was publicly disclosed on October 8, 2025, and a security update was released in version 3.0.8 to address the issue. Attackers leveraging this flaw could gain unauthorized access to sensitive files, modify system configurations, or deploy malicious payloads, potentially leading to full system compromise. The vulnerability affects all installations of Flowise prior to the patched version, though the exact list of affected products and vendors has not been fully enumerated. Security researchers emphasize the critical nature of the flaw due to the ease of exploitation and the broad impact on confidentiality, integrity, and availability. Organizations are strongly advised to upgrade to Flowise version 3.0.8 or later to mitigate the risk. The vulnerability was reported through GitHub security advisories, highlighting the importance of monitoring open-source project disclosures. No evidence of active exploitation in the wild has been reported as of the disclosure date, but the public availability of technical details increases the urgency for remediation. The flaw underscores the risks associated with insufficient input validation in file handling components of web applications. Security teams should review their deployment of Flowise and apply the necessary patches without delay. In addition to patching, organizations should audit access logs for signs of suspicious file operations that could indicate attempted exploitation. The incident serves as a reminder of the critical need for secure coding practices and regular vulnerability assessments in software development.
Oct 8, 2025
Flowise Flaw Lets Unauthenticated Attackers Hijack Sessions and Inject Flow Properties
A high-severity vulnerability in **Flowise**, tracked as `CVE-2026-69258`, allows unauthenticated attackers to tamper with the execution context of public chatflows through the `POST /api/v1/prediction/:id` endpoint. In affected versions before **3.1.3**, the application accepted an `overrideConfig` object and merged it into internal `flowConfig` and `flowData` structures without enforcing `apiOverrideStatus`, enabling attackers to overwrite values such as `sessionId`, `chatId`, and `chatHistory` and bypass session isolation.
The flaw can let attackers access, pollute, or hijack other users’ conversations and inject arbitrary properties into the `$flow.*` namespace used by flow nodes, including variables that may influence SQL queries, webhooks, and API integrations. The issue is rated **CVSS 8.8** and mapped to `CWE-639` and `CWE-915`; while it does not directly provide operating-system-level remote code execution, it can break logical security boundaries and corrupt routing, prompt history, and downstream workflow behavior. Flowise patched the issue in **version 3.1.3**, and users are advised to upgrade.
Aug 5, 2026