Cross-Site Scripting in GitLab Web IDE
CVE-2024-4835 is a high-severity cross-site scripting vulnerability in GitLab Community Edition and Enterprise Edition Web IDE functionality. It affects GitLab versions 15.11 before 16.10.6, 16.11 before 16.11.3, and 17.0 before 17.0.1. The flaw allows an attacker to craft a malicious page that triggers script execution in a victim user's browser in the context of GitLab, enabling theft of sensitive user information. Available reporting associates the issue specifically with the Web IDE and indicates it can be leveraged for 1-click account takeover scenarios.
What it means and what to do now: patch path, interim mitigations, and the assume-compromise checklist.
What an attacker gets, and what they’ve been doing with it.
Successful exploitation can allow exfiltration of sensitive user information from the victim's GitLab session, including data accessible to the browser in the GitLab origin. Because the issue is a Web IDE XSS with scope change and high confidentiality and integrity impact, exploitation may also enable session compromise and 1-click account takeover of targeted users.
If you can’t patch tonight, do this now.
If immediate patching is not possible, reduce exposure to the vulnerable Web IDE feature where operationally feasible, restrict access to GitLab instances to trusted users and networks, and increase monitoring for suspicious Web IDE activity and anomalous account actions. User awareness measures to avoid interacting with untrusted crafted pages may reduce risk, but mitigation is incomplete because the vulnerability is fundamentally server-side product code that requires vendor fixes.
Patch, then assume compromise.
Upgrade GitLab CE/EE to a fixed release: 16.10.6 or later on the 16.10 branch, 16.11.3 or later on the 16.11 branch, or 17.0.1 or later on the 17.0 branch. Organizations running affected self-managed deployments should prioritize patching immediately. GitLab.com was already running a patched version at the time of disclosure.
No public exploits tracked yet. Mallory keeps watching.
Products and vendors Mallory has correlated with this vulnerability. Open in Mallory to drill down to specific CPE configurations and version ranges.
2 sources tracked across advisories, community write-ups, and news. New activity surfaces here as Mallory finds it.