WildFly Elytron CLI Brute-Force Authentication Exposure
CVE-2025-23368 is an improper restriction of excessive authentication attempts in WildFly Elytron integration. The component lacks sufficient protections against multiple failed authentication attempts in a short period, allowing repeated credential guesses through the command-line interface (CLI).
What it means and what to do now: patch path, interim mitigations, and the assume-compromise checklist.
What an attacker gets, and what they’ve been doing with it.
An attacker may conduct brute-force authentication attempts through the WildFly CLI. If valid credentials are guessed, this may result in unauthorized authenticated access at the privilege level of the compromised account.
If you can’t patch tonight, do this now.
No direct workaround is available. Until fixed versions are deployed, monitor network traffic and authentication activity for repeated failed CLI login attempts, and block suspicious traffic where feasible.
Patch, then assume compromise.
Upgrade WildFly Core to 31.0.3.Final, 32.0.0.Beta3, or a later fixed release. For WildFly distributions, upgrade to WildFly 39.0.1.Final or later, or to a WildFly 40 release that includes the fix.
No public exploits tracked yet. Mallory keeps watching.
Products and vendors Mallory has correlated with this vulnerability. Open in Mallory to drill down to specific CPE configurations and version ranges.
3 sources tracked across advisories, community write-ups, and news. New activity surfaces here as Mallory finds it.