Authenticated SSRF in IBM Langflow OSS
IBM Langflow OSS versions 1.0.0 through 1.12.3 contain a server-side request forgery vulnerability that allows an authenticated attacker to cause unauthorized requests to originate from the server. Exploitation may enable network enumeration or facilitate further attacks. The specific vulnerable function and request parameters have not been identified.
What it means and what to do now: patch path, interim mitigations, and the assume-compromise checklist.
What an attacker gets, and what they’ve been doing with it.
An authenticated attacker can abuse the server's network access to issue unauthorized requests, potentially enumerate reachable services, and facilitate attacks against other systems. The assigned CVSS v3.1 score is 5.4, with low confidentiality and integrity impacts.
If you can’t patch tonight, do this now.
No vendor workaround is specified. Interim defensive measures include restricting application access to trusted users and limiting outbound connections to explicitly required destinations, including blocking unnecessary access to internal networks and cloud metadata services. These controls do not replace upgrading.
Patch, then assume compromise.
Upgrade to Langflow OSS 1.12.4, as recommended by IBM. Back up the existing installation, review upgrade preparation instructions and release-specific configuration changes, perform the upgrade, and test existing flows.
No public exploits tracked yet. Mallory keeps watching.
Products and vendors Mallory has correlated with this vulnerability. Open in Mallory to drill down to specific CPE configurations and version ranges.
2 sources tracked across advisories, community write-ups, and news. New activity surfaces here as Mallory finds it.