Credential Disclosure in IBM Langflow OSS
CVE-2026-110192 is an insufficiently protected credentials vulnerability in IBM Langflow OSS versions 1.0.0 through 1.12.8. A remote, low-privileged authenticated attacker can obtain sensitive information, including operator-injected API keys, without the intended authorization. The vulnerability has a CVSS v3.1 score of 6.5 and a high confidentiality impact. The specific vulnerable function and request mechanism are not identified.
What it means and what to do now: patch path, interim mitigations, and the assume-compromise checklist.
What an attacker gets, and what they’ve been doing with it.
Successful exploitation exposes sensitive credentials to an authenticated attacker, compromising the confidentiality of operator-injected API keys and other affected information. Disclosed credentials may permit unauthorized access to associated services within the credentials' permissions. Direct integrity or availability impacts are not established.
If you can’t patch tonight, do this now.
No separate workaround or interim mitigation is documented. Upgrading to a fixed release is the documented resolution.
Patch, then assume compromise.
Upgrade to Langflow OSS 1.13.0 or later. For Python-package deployments, install the fixed release using pip; for Docker deployments, use the version 1.13.0 image or a later fixed image and restart while preserving persistent data. Before upgrading, back up the database, secret key, and uploaded files. Deployments using automatic login should prepare the existing account for password-based sign-in before the upgrade.
No public exploits tracked yet. Mallory keeps watching.
Products and vendors Mallory has correlated with this vulnerability. Open in Mallory to drill down to specific CPE configurations and version ranges.
5 sources tracked across advisories, community write-ups, and news. New activity surfaces here as Mallory finds it.