XSS in GitLab EE Duo Agent output rendering
CVE-2026-6073 is a high-severity cross-site scripting vulnerability in GitLab Enterprise Edition affecting Duo Agent output rendering. The flaw is caused by improper input sanitization of Duo Agent-generated content before it is rendered in the browser, allowing an authenticated attacker to inject arbitrary JavaScript into content that will later be viewed by other users. Affected versions are GitLab EE 18.7 before 18.9.7, 18.10 before 18.10.6, and 18.11 before 18.11.3. The vulnerable functionality was introduced in the 18.7 release line. When a victim views the maliciously crafted Duo Agent output, the injected script executes in the victim's browser context.
What it means and what to do now: patch path, interim mitigations, and the assume-compromise checklist.
What an attacker gets, and what they’ve been doing with it.
Successful exploitation allows arbitrary JavaScript execution in the browsers of other authenticated users who view the malicious content. This can enable session theft, unauthorized actions performed in the victim's context, and exfiltration of data accessible through the victim's browser session. The CVSS v3.1 vector indicates high confidentiality and integrity impact with changed scope, but no direct availability impact.
If you can’t patch tonight, do this now.
If immediate upgrade is not possible, reduce exposure by restricting access to affected GitLab EE instances and limiting use of the vulnerable Duo Agent rendering workflow to trusted users until patched. Because exploitation requires authenticated access and victim viewing of malicious content, minimizing untrusted user access and avoiding rendering untrusted Duo Agent output can reduce risk, but vendor patching is the definitive mitigation.
Patch, then assume compromise.
Upgrade self-managed GitLab Enterprise Edition instances to a fixed release: 18.9.7, 18.10.6, or 18.11.3, depending on the deployed branch. The vendor fix improves sanitization of Duo Agent-returned content before UI rendering so that injected script is not interpreted as executable code by the browser.
No public exploits tracked yet. Mallory keeps watching.
Products and vendors Mallory has correlated with this vulnerability. Open in Mallory to drill down to specific CPE configurations and version ranges.
8 sources tracked across advisories, community write-ups, and news. New activity surfaces here as Mallory finds it.