Privilege Escalation in IBM Langflow OSS via Database Manipulation
CVE-2026-8635 is a privilege escalation vulnerability in IBM Langflow OSS affecting versions 1.0.0 through 1.10.0. The flaw allows an authenticated user with low privileges to directly manipulate application database state in a way that elevates the account to superuser. Once superuser privileges are obtained, the attacker can access privileged functionality that enables arbitrary system command execution, resulting in compromise of the host with the permissions of the Langflow service. The issue is network-reachable, requires no user interaction, and has been associated with CWE-94.
What it means and what to do now: patch path, interim mitigations, and the assume-compromise checklist.
What an attacker gets, and what they’ve been doing with it.
Successful exploitation allows an authenticated attacker to escalate privileges from a low-privileged account to superuser within Langflow OSS. With elevated privileges, the attacker can execute arbitrary system commands and achieve full compromise of the Langflow application environment under the service account context. This can result in complete loss of confidentiality, integrity, and availability for data and workloads accessible to the Langflow service, and may enable broader host compromise depending on service permissions and deployment configuration.
If you can’t patch tonight, do this now.
If immediate patching is not possible, reduce exposure by strictly limiting access to Langflow OSS to trusted users and administrative networks, minimizing the number of authenticated accounts, and monitoring for unauthorized privilege changes or suspicious database modifications. Restrict the Langflow service account to the least privileges necessary at the operating system level to reduce post-exploitation impact. Additional compensating controls should include strong authentication, segmentation of the application from sensitive internal systems, and heightened logging and review of privileged actions until the fixed release can be deployed.
Patch, then assume compromise.
Upgrade IBM Langflow OSS to version 1.10.1 or later, which includes fixes for CVE-2026-8635 and the related Langflow OSS vulnerabilities disclosed in the same advisory set. Ensure all affected instances running versions 1.0.0 through 1.10.0 are updated promptly.
No public exploits tracked yet. Mallory keeps watching.
Products and vendors Mallory has correlated with this vulnerability. Open in Mallory to drill down to specific CPE configurations and version ranges.
9 sources tracked across advisories, community write-ups, and news. New activity surfaces here as Mallory finds it.