Critical Pre-Auth Deserialization Flaw Exposes IBM WebSphere Servers to RCE
Vulnerability Disclosure · 4 sources · Updated 3mo ago · First seen Jul 28, 2026

IBM disclosed two vulnerabilities in traditional IBM WebSphere Application Server affecting versions 9.0 and 8.5, led by CVE-2026-14512, a pre-authentication unsafe deserialization flaw rated CVSS 9.8. The issue could allow a remote attacker to bypass authentication or achieve arbitrary code execution without user interaction, creating a high-risk path to full compromise of exposed WebSphere environments.
IBM also identified CVE-2026-14528, a CVSS 7.4 flaw that could expose sensitive information through insertion into log files. The company directed customers to apply the interim fix for APAR PH72166 or upgrade to Fix Pack 9.0.5.29+ for WebSphere 9.0 and Fix Pack 8.5.5.31+ for WebSphere 8.5, and said no workarounds or mitigations are available.


