Attackers Exploit Critical Langflow RCE to Harvest Cloud and SSH Credentials
Active Exploitation · 10 sources · Updated 2mo ago · First seen Sep 1, 2026

Threat actors are actively exploiting CVE-2026-0768, a critical unauthenticated remote-code-execution flaw in the Langflow AI low-code platform. Rated CVSS 9.8, the vulnerability affects Langflow versions through 1.4.2 and allows arbitrary Python code execution as root through insufficient validation in the custom-component editor’s code validator. VulnCheck recorded more than 360 exploitation attempts against U.K. canaries, largely from Russian-origin infrastructure, seeking environment variables, Langflow secrets, SSH details, and shell-history metadata.
The activity follows broader disclosures affecting Langflow OSS 1.x releases prior to 1.11.2, including critical and high-severity flaws enabling RCE, privilege escalation, arbitrary file reads, and information disclosure. Organizations should upgrade Langflow to the vendor-fixed releases—at least 1.11.2 where applicable—remove public exposure where possible, rotate credentials accessible to Langflow, and investigate for unauthorized environment-variable access, proxy deployment, cryptomining, audit-log changes, and lateral scanning. Public exploit development is also progressing: a proposed Metasploit module targets the separate authenticated RCE CVE-2026-5027.


